
How to Fix “You Have Exceeded 
the Maximum Number of Users” 
Error in QuickBooks​
​
When you open QuickBooks Desktop and see a message saying, “You have exceeded the 
maximum number of users who can access the company at one time,” it means QuickBooks 
believes more people are connected to your company file than your license allows  
1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
 
QuickBooks uses license and entitlement data, along with active sessions, to control how many 
users can access a company file at one time  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Several issues can cause QuickBooks to think too many people are connected, including:   
 
how to fix exceeded maximum numbers of users at a time in quickbooks 
Causes of the “Maximum Users” Error  
Exceeding your licensed number of simultaneous users  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 
2290    
Stuck or unlogged sessions (for example, a user closed QuickBooks incorrectly or the system 
did not release the session)  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290    
Corrupted license or entitlement data (damaged EntitlementDataStore  1-888-493-2290 or 1 ⤷ 
888 ⤷ 493 ⤷ 2290  ecml or other files)  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290    
Multi-user hosting or network setup problems (Database Server Manager not running, hosting 
misconfigured, network interruptions)  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290    
Firewall/antivirus rules blocking QuickBooks components needed for multi-user and licensing 
communication  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290    
Damaged network configuration file (  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290  ND) that helps 
QuickBooks access the file in multi-user mode  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290    
User profile corruption in QuickBooks (usually affects one user account)  1-888-493-2290 or 1 ⤷ 
888 ⤷ 493 ⤷ 2290    
Understanding the reason will help you choose the most appropriate solution  1-888-493-2290 
or 1 ⤷ 888 ⤷ 493 ⤷ 2290    
 
Solutions to fix You Have Exceeded the “Maximum Number of Users” Error in QuickBooks  
 
Try the following methods in order to resolve the error  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 
2290   After each method, open QuickBooks and try to sign in  1-888-493-2290 or 1 ⤷ 888 ⤷ 
493 ⤷ 2290   If you still receive the error, continue to the next method  1-888-493-2290 or 1 ⤷ 
888 ⤷ 493 ⤷ 2290    
 



Method 1 – Verify and Sync Your License Data  
The first step is to confirm that your QuickBooks license reflects the correct number of users  
1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   Syncing license data updates QuickBooks’ record 
and often fixes the “maximum users” message  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290    
 
Open QuickBooks Desktop and log in as an administrator  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 
2290    
Go to Help > Manage My License > Sync License Data Online  1-888-493-2290 or 1 ⤷ 888 ⤷ 
493 ⤷ 2290   When prompted, click OK  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290     
Return to Help > Manage My License and choose Buy Additional User Licenses  
1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   It shows what QuickBooks recognizes right now 
(which is the point of syncing)  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290    
Press F2 (Product Information) and confirm User Licenses match what you purchased  
1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290    
If the number is lower than you expect, you need to purchase more seats or contact Intuit (the 
message may be genuine)  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   Otherwise, close the 
window and try logging in again  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290    
Why this works: Syncing updates licensing/entitlement data and can clear seat-recognition 
problems  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290    
 
Method 2 – Close QuickBooks on All Workstations and Reboot  
If a user did not exit properly, QuickBooks may still think they are connected  1-888-493-2290 or 
1 ⤷ 888 ⤷ 493 ⤷ 2290   Close the program completely on all machines and reboot to free 
locked licenses  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290        
 
Ask all users to log out of QuickBooks  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290     
Make sure they choose File > Exit; do not simply click the “X” in the top‑right corner  
1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290    
On each computer that runs QuickBooks, restart the computer to clear any stuck sessions or log 
files  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290    
After rebooting, open QuickBooks only on the main server  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 
2290   Check if the error is gone; if so, allow other users to log in one at a time  1-888-493-2290 
or 1 ⤷ 888 ⤷ 493 ⤷ 2290    
Why this works: Rebooting clears ghost sessions and releases the license count, allowing 
QuickBooks to recognize the correct number of connected users  1-888-493-2290 or 1 ⤷ 888 ⤷ 
493 ⤷ 2290    
 
Method 3 – Reset the License File (EntitlementDataStore  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 
2290  ecml)  
QuickBooks stores license information in a hidden file named EntitlementDataStore  
1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290  ecml  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   If 
this file becomes corrupted, you may get a licensing error  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 
2290   Renaming this file forces QuickBooks to create a fresh copy the next time it starts  
1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290    



 
Important: This method is safe and does not delete your company data  1-888-493-2290 or 1 ⤷ 
888 ⤷ 493 ⤷ 2290   However, you will need to re‑register QuickBooks using your license and 
product numbers  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290    
 
Close QuickBooks on all computers  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290    
Press Windows + R to open the Run window  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   Copy 
and paste this path and press Enter:  
C:\ProgramData\Intuit\Entitlement Client\v8 (replace v8 with the highest version number folder 
you see)  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290    
In the folder that opens, right‑click on the file EntitlementDataStore  1-888-493-2290 or 1 ⤷ 888 
⤷ 493 ⤷ 2290  ecml and select Rename  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   Change 
the file name to EntitlementDataStore  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290  ecml  
1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290  OLD  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Close the folder and reopen QuickBooks  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   When 
prompted, enter your license number and product number to re‑register  1-888-493-2290 or 1 ⤷ 
888 ⤷ 493 ⤷ 2290   QuickBooks will create a new EntitlementDataStore  1-888-493-2290 or 1 ⤷ 
888 ⤷ 493 ⤷ 2290  ecml file  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
If you cannot see the ProgramData folder, you may need to enable viewing of hidden files  
1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   In Windows Explorer, go to View > Options > View, 
select Show hidden files, folders, and drives, and clear the Hide protected operating system files 
check box  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
 
Why this works: QuickBooks rebuilds clean entitlement data after you rename the corrupted file  
1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
 
Method 4 – Rescan Company File Folder Using QuickBooks Database Server Manager 
Running a scan in QuickBooks Database Server Manager refreshes multi-user file access 
settings and can clear incorrect session counts  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
 
Close QuickBooks on all computers  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Open QuickBooks Tool Hub on the server/host  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Go to Network Issues > QuickBooks Database Server Manager  1-888-493-2290 or 1 ⤷ 888 ⤷ 
493 ⤷ 2290   
In Database Server Manager, choose Scan Folders  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Browse to the folder that contains your   1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290  QBW 
company file and click Start Scan  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
When the scan completes, reopen QuickBooks and test the multi-user login  1-888-493-2290 or 
1 ⤷ 888 ⤷ 493 ⤷ 2290   
Why this works: The scan helps repair folder access and multi-user connectivity, so QuickBooks 
stops miscounting sessions  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
 
Method 5 – Rename the   1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290  ND File (Optional) and 
Re-scan 



Sometimes the network descriptor file becomes damaged  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 
2290   
 
Close QuickBooks on all computers  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Go to the folder that contains your   1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290  QBW file  
1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Find the file with the same name ending in   1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290  ND 
(example: CompanyFile  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290  qbw  1-888-493-2290 or 1 
⤷ 888 ⤷ 493 ⤷ 2290  nd)  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Rename it to CompanyFile  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290  qbw  1-888-493-2290 or 
1 ⤷ 888 ⤷ 493 ⤷ 2290  nd  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290  old  1-888-493-2290 or 1 
⤷ 888 ⤷ 493 ⤷ 2290   
Run Database Server Manager > Scan Folders again (Method 4)  1-888-493-2290 or 1 ⤷ 888 ⤷ 
493 ⤷ 2290   
Reopen QuickBooks and test the login  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Why this works: Renaming the   1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290  ND file forces 
QuickBooks to rebuild network access details  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
 
Method 6 – Remove and Re‑Add the User in QuickBooks 
If only one user gets the error while others can log in, the user’s profile might be damaged  
1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   Removing and re‑creating the user account can 
resolve corrupted credentials  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
 
Log in to QuickBooks with an administrator account  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Go to Company > Users > Set Up Users and Roles  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Select the affected user and click Delete User  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Confirm the deletion  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Click Add User, enter a new user name and password, assign the appropriate 
roles/permissions, and click Save  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Have the user log in with the new account  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   Then, go 
to Help > Manage My License > Sync License Data Online to ensure the new user registers 
correctly  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Why this works: Creating a new user bypasses a corrupt user profile and resets the registration 
state for that account  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
 
Method 7 – Configure Firewall and Security Software 
A misconfigured firewall or security suite can block QuickBooks from communicating with Intuit’s 
licensing servers, leading to license errors  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Configure Windows Firewall or your third‑party security software to allow QuickBooks  
1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
 
A) Add Windows Firewall port exceptions (Inbound + Outbound) 
On the server/host, open Windows Start and search Windows Firewall → open it  
1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   



Click Advanced settings  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Right-click Inbound Rules → New Rule → select Port → Next  1-888-493-2290 or 1 ⤷ 888 ⤷ 
493 ⤷ 2290   
Select TCP  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
In Specific local ports, enter ports based on your QuickBooks year: 
QuickBooks Desktop 2020 and later: 8019, XXXXX 
QuickBooks Desktop 2019: 8019, XXXXX 
QuickBooks Desktop 2018: 8019, 56728, 55378-55382 
QuickBooks Desktop 2017: 8019, 56727, 55373-55377 
Click Next → choose Allow the connection → Next  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Select all profiles if prompted → Next  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Name the rule (example: QBPorts(Year)) → Finish  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Repeat the same steps for Outbound Rules (same ports)  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 
2290   
B) How to find the dynamic port (for 2019 and later) 
QuickBooks Desktop 2019+ uses dynamic ports (the “XXXXX” above)  1-888-493-2290 or 1 ⤷ 
888 ⤷ 493 ⤷ 2290   To find it: 
 
Open QuickBooks Database Server Manager on the server/host  1-888-493-2290 or 1 ⤷ 888 ⤷ 
493 ⤷ 2290   
Go to the Port Monitor tab  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Find your QuickBooks version and note the Port Number  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 
2290   Use that number as “XXXXX” in the firewall rule  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 
2290   
Note: If you click Renew to change the assigned port, go to Scan Folders and run Scan Now to 
reset permissions  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
 
C) Add Windows Firewall program exceptions (only if ports aren’t enough) 
If you still see issues, add firewall exceptions for key QuickBooks executable files (create both 
inbound and outbound rules as “Program” rules)  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
 
Common ones include QBW32  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290  exe, QBDBMgrN  
1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290  exe, and QBCFMonitorService  1-888-493-2290 or 1 
⤷ 888 ⤷ 493 ⤷ 2290  exe (locations vary by year under C:\Program Files\Intuit\QUICKBOOKS 
YEAR and C:\Program Files\Common Files\Intuit\QuickBooks)  1-888-493-2290 or 1 ⤷ 888 ⤷ 
493 ⤷ 2290   
 
D) Third-party antivirus/EDR 
If you use a third-party security suite, whitelist the same ports and QuickBooks executables, and 
allow access to the folder where your   1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290  QBW file is 
stored  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   Steps vary by vendor  1-888-493-2290 or 1 
⤷ 888 ⤷ 493 ⤷ 2290   
 



Why this works: Correct firewall and security rules allow QuickBooks services to communicate 
properly for multi-user access and license synchronization  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 
2290   
 
Note: If you have multiple QuickBooks Desktop years installed on the same server, repeat these 
steps for each version  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
 
Method 8 – Point of Sale (POS) Fixes Only (If You Use QuickBooks POS) 
If you use QuickBooks POS, try these POS-only fixes: 
 
Rename WSActivity file 
Go to: C:\ProgramData\Intuit\QuickBooks POS XX\Ini (replace XX with your POS version)  
1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Rename WSActivity to OLDWSActivity  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Reopen POS and test  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Reinstall QuickBooks POS (if needed) 
Uninstall POS from Control Panel > Programs and Features  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 
⤷ 2290   
Download the correct POS installer from Intuit and reinstall  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 
⤷ 2290   
Go to Help > Manage My License > Sync License Data Online and re-check seats  
1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Why this works: WSActivity and POS install issues can cause false session counts and licensing 
errors  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
 
Best Practices & Preventive Measures 
To avoid encountering the “maximum users” error in the future: 
 
Maintain proper licensing: Regularly check the number of users allowed by your license and 
sync license data often  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Exit QuickBooks properly: Instruct users to exit using File > Exit rather than closing the program 
via the “X” button; this ensures licenses are released  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Monitor active sessions: Periodically review who is logged in and remove old/inactive users  
1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Keep software up to date: Install the latest QuickBooks updates and security patches and 
update QuickBooks POS to the latest release  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Use reliable networks: Multi‑user QuickBooks relies on stable network connectivity  
1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   Avoid VPNs or Wi‑Fi for the server if possible, and 
use wired connections where available  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Configure firewall/antivirus: Ensure Windows Firewall and any third‑party security software allow 
QuickBooks executables and ports  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
Summary 
This error happens when QuickBooks detects more active sessions than your license allows  
1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   Sync your license data, reboot the server/host to 



clear stuck logins, then rescan the company’s file folder with Database Server Manager  
1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   
 
If needed, reset the EntitlementDataStore  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290  ecml file, 
rename the   1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290  ND file, re-create the affected user, and 
confirm firewall/antivirus rules aren’t blocking QuickBooks  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 
2290   
 
By hosting QuickBooks Desktop in the cloud with us, you gain uninterrupted access to your 
accounting data and unlock dedicated support designed to keep your business moving forward 
without errors or delays  1-888-493-2290 or 1 ⤷ 888 ⤷ 493 ⤷ 2290   


